当前位置:首页 > 问答

通达信底背离画图函数

我来帮TA回答

通达信有没有什么指标可以判断macd底背离的有的话发几张图看看?

通达信系统不自带这样的指标,需要用户根据自己需要的条件编写,例如下图中的macd柱的顶底背离自动画线指标.

请高手把下面的通达信指标改写成底背离的选股公式

FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
底背离:CROSS(FF,MA15);

求高手帮忙设:通达信macd 顶底背离+画线公式,如图,图片来自同花顺,万分感激!

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;

DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
DU:=BARSLAST(CROSS(DIF,DEA));
DD:=BARSLAST(CROSS(DEA,DIF));
TJ1:=DEA<0 AND DU=0 AND REF(DEA,REF(DU,1))<DEA AND REF(C,REF(DU,1))>C;
STICKLINE(EVERY(UPNDAY(DU,1),DU),REF(DEA,DU),REF(DEA,DU),5,-1),COLORLIGRAY;
STICKLINE(TJ1,REF(DEA,REF(DU+1,1)),DEA,1,0),COLORLIGRAY;
DRAWTEXT(TJ1,REF(DEA,REF(DU,1)),'底背离'),COLORLIGRAY;
TJ2:=DEA>0 AND DD=0 AND REF(DEA,REF(DD,1))>DEA AND REF(C,REF(DD,1))<C;
STICKLINE(EVERY(UPNDAY(DD,1),DD),REF(DEA,DD),REF(DEA,DD),5,-1),COLORLIGRAY;
STICKLINE(TJ2,REF(DEA,REF(DD+1,1)),DEA,1,0),COLORLIGRAY;
DRAWTEXT(TJ2,REF(DEA,REF(DD,1)),'顶背离'),COLORLIGRAY;

求高手编一个通达信MACD底背离的公式

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
STICKLINE(B1>0,-0.1,0,2,0),COLORRED;
STICKLINE(B2>0,-0.1,0,2,0),COLORFF00FF;
STICKLINE(B3>0,-0.1,0,2,0),COLORYELLOW;
STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;

{希望能够帮到您,也祝您投资顺利}

如何将通达信的排序指标,变成选股公式?

通达信软件的排序功能,你是用指标排列出数值第一?
如果是想直接改写为选股公式,速度上会慢些。
要使用横向统计函数,可以编写。

通达信的 排序指标如何添加?如何调用自己添加的排序指标?

菜单--功能--选股器--综合选股--选择你要排序的指标--在条件设置下方第三栏找到排名前--下面一栏填写范围--加入条件--选股至版块。然后到该版块看到的就是排好序的股票。